$re = '/((<(\s*)(script)(\s*)(\/*)(\s*)>((.|\n)*?)<(\s*)(\/+)(\s*)(script)(\s*)>)|<(\s*)(\/*)(\s*)(script)(\s*)(\/*)(\s*)>)*/';
$str = '<script>alert(\'Hello World\');
alert(\'Hello Back\');<script>alert(\'Hello World\');
alert(\'Hello Back\');</script></script>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);