import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((<(\\s*)(script)(\\s*)(\\/*)(\\s*)>((.|\\n)*?)<(\\s*)(\\/+)(\\s*)(script)(\\s*)>)|<(\\s*)(\\/*)(\\s*)(script)(\\s*)(\\/*)(\\s*)>)*";
final String string = "<script>alert('Hello World');\n"
+ "alert('Hello Back');<script>alert('Hello World');\n"
+ "alert('Hello Back');</script></script>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}