package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((<(\s*)(script)(\s*)(\/*)(\s*)>((.|\n)*?)<(\s*)(\/+)(\s*)(script)(\s*)>)|<(\s*)(\/*)(\s*)(script)(\s*)(\/*)(\s*)>)*`)
var str = `<script>alert('Hello World');
alert('Hello Back');<script>alert('Hello World');
alert('Hello Back');</script></script>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}