re = /^([a-z]:)(((\\|\/)[a-z0-9^&'@{}\[\],$=!\-#\(\)%\.\+~_]+)*(\\|\/))([^\\\/:\*\"<>\|]+\.[a-z0-9]+)/i
str = 'C:\\Users\\username\\abcde\\abcd\\dd.d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end