import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z]:)(((\\\\|\\/)[a-z0-9^&'@\\{\\}\\[\\],$=!\\-#\\(\\)%\\.\\+~_]+)*(\\\\|\\/))([^\\\\\\/:\\*\\\"<>\\|]+\\.[a-z0-9]+)";
final String string = "C:\\Users\\username\\abcde\\abcd\\dd.d";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}