package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^([a-z]:)(((\\|\/)[a-z0-9^&'@{}\[\],$=!\-#\(\)%\.\+~_]+)*(\\|\/))([^\\\/:\*\"<>\|]+\.[a-z0-9]+)`)
var str = `C:\Users\username\abcde\abcd\dd.d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}