re = /\^\[(?:\[[^@-~]+[\@-\~]|[0-9@-_])/
str = 'Tue Feb 25 16:53:54 2014: [....] Starting NTP server: ntpd^[[?25l^[[?1c^[7^[[1G[^[[32m ok ^[[39;49m^[8^[[?25h^[[?0c.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end