package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\^\[(?:\[[^@-~]+[\@-\~]|[0-9@-_])`)
var str = `Tue Feb 25 16:53:54 2014: [....] Starting NTP server: ntpd^[[?25l^[[?1c^[7^[[1G[^[[32m ok ^[[39;49m^[8^[[?25h^[[?0c.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}