use strict;
my $str = 'glib jocks vex dwarves!';
my $regex = qr/(dw)|(v)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";