re = /\b(?<password>(?=.*?[A-Z])(?=.*?[a-z])(?=.*?\d)(?=.*?[-#?!@$%^&*]).[^ ]{12,})/m
str = 'this is a pasword test: Sup3rP@ssword'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end