$re = '/\b(?<password>(?=.*?[A-Z])(?=.*?[a-z])(?=.*?\d)(?=.*?[-#?!@$%^&*]).[^ ]{12,})/m';
$str = 'this is a pasword test: Sup3rP@ssword';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);