import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<password>(?=.*?[A-Z])(?=.*?[a-z])(?=.*?\\d)(?=.*?[-#?!@$%^&*]).[^ ]{12,})";
final String string = "this is a pasword test: Sup3rP@ssword";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}