# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^120/BHP\d/(?P<lblreq_board>LBLREQ)-(?P<lblreq_id>\d+)/(?P<mission>\d{4}-\d{2}-\d{2}-Z0F\d{4})/(?P<run>\d+)/(?P<vehicle_time>\d{18})/(?P<event_time_s>\d+\.\d+)/(?:sweep_dir_\d+/sweep_\d+/)?image_(?P<channel>[a-z_]+)_000000000\.png$"
test_str = ("120/BHP4/LBLREQ-92/2018-06-13-Z0F0034/2/347742483826079513/315970791.448747000/sweep_dir_0/sweep_0/image_raw_ring_front_center_000000000.png\n"
"120/BHP4/LBLREQ-99/2018-07-05-Z0F0026/2/305006254539769513/315967941.329407000/sweep_dir_0/sweep_0/image_raw_stereo_front_left_000000000.png")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.