const regex = new RegExp('((\\.{2}\\/{1})+|((\\.{1}\\/{1})?)|(\\/{1}))(([a-zA-Z0-9]+\\/{1})+)([a-zA-Z0-9])+(\\.{1}[a-zA-Z0-9]+)?$', '')
const str = `../../dir/SubDir1/SubDir2/file.ext`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}