import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\.{2}\\/{1})+|((\\.{1}\\/{1})?)|(\\/{1}))(([a-zA-Z0-9]+\\/{1})+)([a-zA-Z0-9])+(\\.{1}[a-zA-Z0-9]+)?$";
final String string = "../../dir/SubDir1/SubDir2/file.ext";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}