package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\.{2}\/{1})+|((\.{1}\/{1})?)|(\/{1}))(([a-zA-Z0-9]+\/{1})+)([a-zA-Z0-9])+(\.{1}[a-zA-Z0-9]+)?$`)
var str = `../../dir/SubDir1/SubDir2/file.ext`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}