re = /#(?![\da-f]{6}|[\da-f]{3}).{0,7}/m
str = 'html{
color: #e1e1e;
background-color: #1e1e1e;
}
body{
color: #55432c;
background-color: #53e;
}
div{
color: #55h32c;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end