import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#(?![\\da-f]{6}|[\\da-f]{3}).{0,7}";
final String string = "html{ \n"
+ " color: #e1e1e;\n"
+ " background-color: #1e1e1e;\n"
+ "}\n"
+ "body{\n"
+ " color: #55432c;\n"
+ " background-color: #53e; \n"
+ "}\n"
+ "div{\n"
+ " color: #55h32c;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}