const regex = /#(?![\da-f]{6}|[\da-f]{3}).{0,7}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#(?![\\da-f]{6}|[\\da-f]{3}).{0,7}', 'gm')
const str = `html{
color: #e1e1e;
background-color: #1e1e1e;
}
body{
color: #55432c;
background-color: #53e;
}
div{
color: #55h32c;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}