$re = '/^(?!\s*[#])\S.*/m';
$str = '#Use \'#\' for commenting hosts
ibin-dev-build
#ibin-dev1
# ibin-dev2
ibin-bdl-adapter
#ibin-elk
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);