import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\s*[#])\\S.*";
final String string = "#Use '#' for commenting hosts\n"
+ " \n"
+ " \n"
+ "ibin-dev-build\n"
+ "#ibin-dev1\n"
+ "# ibin-dev2\n"
+ "ibin-bdl-adapter\n"
+ " #ibin-elk\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}