#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\s*[#])\S.*"
Local $sString = "#Use '#' for commenting hosts" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"ibin-dev-build" & @CRLF & _
"#ibin-dev1" & @CRLF & _
"# ibin-dev2" & @CRLF & _
"ibin-bdl-adapter" & @CRLF & _
" #ibin-elk" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")