re = /([a-zA-Z]+)(\.)([a-zA-Z\-\']+)(@)(bjss\.com)/
str = 'Hello.Goodbye@bjss.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end