$re = '/([a-zA-Z]+)(\.)([a-zA-Z\-\']+)(@)(bjss\.com)/';
$str = 'Hello.Goodbye@bjss.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);