using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z]+)(\.)([a-zA-Z\-\']+)(@)(bjss\.com)";
string input = @"Hello.Goodbye@bjss.com";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}