$re = '/([a-z]+\(([^()]*)\))/m';
$str = '
eq(a,a),eq(b,b)
eq(b,b)
or(eq(a,a),eq(b,b))
and(or(eq(a,a),eq(b,b)),or(eq(a,a),eq(b,b)))
and(eq(a,a),or(eq(b,b),eq(c,c))
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);