package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z]+\(([^()]*)\))`)
var str = `
eq(a,a),eq(b,b)
eq(b,b)
or(eq(a,a),eq(b,b))
and(or(eq(a,a),eq(b,b)),or(eq(a,a),eq(b,b)))
and(eq(a,a),or(eq(b,b),eq(c,c))
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}