using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z]+\(([^()]*)\))";
string input = @"
eq(a,a),eq(b,b)
eq(b,b)
or(eq(a,a),eq(b,b))
and(or(eq(a,a),eq(b,b)),or(eq(a,a),eq(b,b)))
and(eq(a,a),or(eq(b,b),eq(c,c))
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}