re = /^.+_[0-9]{3}\.wmo$/m
str = 'DuskwooAbandoned_Barn.wmo
DuskwooAbandoned_Barn_000.wmo
DuskwooAbandoned_Barn_001.wmo
DuskwooAbandoned_Barn_002.wmo
DuskwooAbandoned_Barn01.wmo
DuskwooAbandoned_Barn01_000.wmo
DuskwooAbandoned_Barn_01.wmo
DuskwooAbandoned_Barn_01_000.wmo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end