package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.+_[0-9]{3}\.wmo$`)
var str = `DuskwooAbandoned_Barn.wmo
DuskwooAbandoned_Barn_000.wmo
DuskwooAbandoned_Barn_001.wmo
DuskwooAbandoned_Barn_002.wmo
DuskwooAbandoned_Barn01.wmo
DuskwooAbandoned_Barn01_000.wmo
DuskwooAbandoned_Barn_01.wmo
DuskwooAbandoned_Barn_01_000.wmo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}