$re = '/^.+_[0-9]{3}\.wmo$/m';
$str = 'DuskwooAbandoned_Barn.wmo
DuskwooAbandoned_Barn_000.wmo
DuskwooAbandoned_Barn_001.wmo
DuskwooAbandoned_Barn_002.wmo
DuskwooAbandoned_Barn01.wmo
DuskwooAbandoned_Barn01_000.wmo
DuskwooAbandoned_Barn_01.wmo
DuskwooAbandoned_Barn_01_000.wmo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);