$re = '/@"^([\u00c0-\u01ffa-zA-Z\'\-])+$"/';
$str = 'aaa1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);