const regex = /@"^([\u00c0-\u01ffa-zA-Z'\-])+$"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@"^([\\u00c0-\\u01ffa-zA-Z\'\\-])+$"', '')
const str = `aaa1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}