package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@"^([\u00c0-\u01ffa-zA-Z'\-])+$"`)
var str = `aaa1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}