$re = '/\S+\[v=\"(kennis)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\/data\/(\w+)/';
$str = 'root/1-825-KennisAPI[v="kennis-adhoc",g="asofdate",p="{"asOfDate":"2017-07-31"}"]/data/as_of_date';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);