import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S+\\[v=\\\"(kennis)-(\\w+)\\\",g=\\\"(\\w+)\\\",p=\\\"(\\S+)\\\"\\]\\/data\\/(\\w+)";
final String string = "root/1-825-KennisAPI[v=\"kennis-adhoc\",g=\"asofdate\",p=\"{\"asOfDate\":\"2017-07-31\"}\"]/data/as_of_date";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}