using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S+\[v=\""(kennis)-(\w+)\"",g=\""(\w+)\"",p=\""(\S+)\""\]\/data\/(\w+)";
string input = @"root/1-825-KennisAPI[v=""kennis-adhoc"",g=""asofdate"",p=""{""asOfDate"":""2017-07-31""}""]/data/as_of_date";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}