re = /(?<!\d)\d{6,7}([^a-zA-Z\d:]+\d{1,2}){0,}(?!\d)+/m
str = 'test 1234567/01 test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end