$re = '/(?<!\d)\d{6,7}([^a-zA-Z\d:]+\d{1,2}){0,}(?!\d)+/m';
$str = 'test 1234567/01 test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);