const regex = /(?<!\d)\d{6,7}([^a-zA-Z\d:]+\d{1,2}){0,}(?!\d)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)\\d{6,7}([^a-zA-Z\\d:]+\\d{1,2}){0,}(?!\\d)+', 'gm')
const str = `test 1234567/01 test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}