$re = '/
.*((black\-?friday\.ga)|(alibestsale\.com)|(build\-?a\-?better\-?business\.2your\.site)|(callmebold\.com)|(centurylink\.net)|(cyber\-?monday\.ga)|(digg\.com)|(euro\.typepad\.jp)|(exmail\.qq\.com)).*
/';
$str = '
.*((black\\-?friday\\.ga)|(alibestsale\\.com)|(build\\-?a\\-?better\\-?business\\.2your\\.site)|(callmebold\\.com)|(centurylink\\.net)|(cyber\\-?monday\\.ga)|(digg\\.com)|(euro\\.typepad\\.jp)|(exmail\\.qq\\.com)).*
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);