#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "" & @CRLF & _
".*((black\-?friday\.ga)|(alibestsale\.com)|(build\-?a\-?better\-?business\.2your\.site)|(callmebold\.com)|(centurylink\.net)|(cyber\-?monday\.ga)|(digg\.com)|(euro\.typepad\.jp)|(exmail\.qq\.com)).*" & @CRLF & _
""
Local $sString = "" & @CRLF & _
".*((black\-?friday\.ga)|(alibestsale\.com)|(build\-?a\-?better\-?business\.2your\.site)|(callmebold\.com)|(centurylink\.net)|(cyber\-?monday\.ga)|(digg\.com)|(euro\.typepad\.jp)|(exmail\.qq\.com)).*" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")