import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\n"
+ ".*((black\\-?friday\\.ga)|(alibestsale\\.com)|(build\\-?a\\-?better\\-?business\\.2your\\.site)|(callmebold\\.com)|(centurylink\\.net)|(cyber\\-?monday\\.ga)|(digg\\.com)|(euro\\.typepad\\.jp)|(exmail\\.qq\\.com)).*\n";
final String string = "\n"
+ ".*((black\\-?friday\\.ga)|(alibestsale\\.com)|(build\\-?a\\-?better\\-?business\\.2your\\.site)|(callmebold\\.com)|(centurylink\\.net)|(cyber\\-?monday\\.ga)|(digg\\.com)|(euro\\.typepad\\.jp)|(exmail\\.qq\\.com)).*\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}