import Foundation
let pattern = #"^(?:0814|0815|0816|0855|0856\d|0857\d|0858\d|0859\d|0[^08]\d)\d{6,9}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
^\d{11}$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}