re = /^(?:0814|0815|0816|0855|0856\d|0857\d|0858\d|0859\d|0[^08]\d)\d{6,9}$/
str = '^\\d{11}$
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end