const regex = /^(?:0814|0815|0816|0855|0856\d|0857\d|0858\d|0859\d|0[^08]\d)\d{6,9}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:0814|0815|0816|0855|0856\\d|0857\\d|0858\\d|0859\\d|0[^08]\\d)\\d{6,9}$', '')
const str = `^\\d{11}\$
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}