re = /^(0[1-9]|[12][0-9]|3[01])[\/]([01][12])[\/]([1-9][0-9]{3})$/
str = '12/12/2052'
# Print the match result
str.match(re) do |match|
puts match.to_s
end