const regex = /^(0[1-9]|[12][0-9]|3[01])[/]([01][12])[/]([1-9][0-9]{3})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0[1-9]|[12][0-9]|3[01])[\/]([01][12])[\/]([1-9][0-9]{3})$', '')
const str = `12/12/2052`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}