package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(0[1-9]|[12][0-9]|3[01])[/]([01][12])[/]([1-9][0-9]{3})$`)
var str = `12/12/2052`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}