// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)[\n]+\s+public function [a-z]+[(][a-zA-Z0-9=',]+[)]\n+\s+[{]\n(.+?)\n+\s+[}]").unwrap();
let string = "class T
{
public function abc(dsv)
{
sdvdsv;csdcsd
sdcsdcsdc
}
public function abc(dsv)
{
sdvdsv;csdcsd
sdcsdcsdc
}
}
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}